Kategorien
Alles Technisch

Probleme mit YouTube Videos in Safari auf iPadOS

Eines der tollsten Features des iOS-Ablegers iPadOS ist das sogenannten Desktop Class Browsing, also die Möglichkeit, im Safari Browser nicht mehr nur mobile Webseiten, sondern normale Webseiten-Ansichten aufzurufen, wie man sie von Desktop-Rechnern und Laptops kennt. Dies ist zum Beispiel sinnvoll für Office-Webanwendungen, die zuvor mit einem iPad nicht genutzt werden konnten. Tolle Sache, die auch grundsätzlich super funktioniert.

Leider existiert seit Erscheinen von iPadOS (auch in der aktuellen Version 13.3) ein Problem, wenn man etwas bei Google sucht, ein YouTube Video angeboten bekommt und dieses im Browser ansehen möchte. YouTube Videos werden trotz aktiviertem Desktop-Browsing mit der Adresse m.youtube.com geöffnet, also der mobilen Variante. Dies passiert bei jedem Aufruf aus Google-Suchergebnissen und führt dazu, dass die Videos nicht gestartet werden können und eine Fehlermeldung erscheint, Safari könne die Seite nicht öffnen, da die Adresse ungültig sei.

Offenbar kommt es zu dem Fehler, weil Google an der Stelle grundsätzlich auf die mobile Seite umleitet, der Browser aber mit der Desktop-Seite rechnet. Klickt man neben der Adressleiste auf das „aA“-Symbol, kann man diverse Einstellungen vornehmen und in einem solchen Fall die mobile Seite anfordern. Das Video kann dann zwar abgespielt werden, stellt aber nur niedrige Auflösungen zur Verfügung und scheint sich auch bei den Kontrollen wie Play und Pause eigenartig zu verhalten. Über das „aA“-Symbol kann dieses Verhalten (oder die Reader Einstellung) fest eingestellt werden.

Natürlich gibt es auch noch die YouTube App, die ich aus diversen Gründen aber nicht nutzen möchte. Vornehmlich wegen der penetranten Werbeeinblendungen. HTML 5 sollte mich auch gar nicht in eine App zwingen. Daher habe ich derzeit nur die Möglichkeit, YouTube jedesmal auf die mobile Variante umzuschalten und keine hochaufgelösten Videos zu sehen. Oder auf das MacBook auszuweichen.

Letztlich stellt sich mir die Frage, wo das Problem liegt. Ist es ein Bug von iPadOS? Ist es ein Bug auf Seiten Google? Ist es bewusstes Verhalten von Google? Sind es mal wieder Sturheit und Streitigkeiten von beiden Seiten? Bislang konnte ich keine Antworten zu finden. Technisch kann es kein Problem sein, die YouTube Seite korrekt als Desktop Variante aufzurufen und die Videos korrekt anzuzeigen. Hat vielleicht einer meiner Leser eine Idee?

0

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

* DSGVO Abfrage zur Speicherung von Benutzerdaten

*

Ich stimme zu. (Pflichtfeld)